0424-North America-Mobile-Pay-Release-25.0.1 #12576

Incident Report for NCR Voyix Aloha

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 14:12 UTC

Investigating

This release includes system updates and routine bug fixes.
expected downtime: 0 minutes
Posted Apr 23, 2025 - 15:35 UTC
This incident affected: North America (Mobile Pay-US).